Currently, the structuring of the commands are the main difference between Classic and Named Mode, but aside from all new features to come only being supported in multi-af mode, there are a few changes already.
Changes in Named Mode compared to Classic Mode includes some of the following:
- The Wide Metric is enabled causing the metric to be further scaled due to it being too large for what is allowed in the RIB
- The delay is now measured in picoseconds instead of microseconds
- Authentication now supports SHA-256 along with the old MD5
- SHA authentication does not support key chains and therefore do not support key rotation
R1#show running-config | section router eigrp
router eigrp 100
metric weights 0 0 0 1 0 0
network 10.0.0.0 0.0.0.255
network 192.168.0.1 0.0.0.0
passive-interface Loopback0
R1#show running-config | section (interface (GigabitEthernet1|Loopback0))
interface Loopback0
ip address 192.168.0.1 255.255.255.0
interface GigabitEthernet1
ip address 10.0.0.1 255.255.255.0
no ip split-horizon eigrp 100
passive-interface Loopback0
As seen above, EIGRP has been configure with a non-default K-value configuration, two network statements and a passive-interface. Now, below the EIGRP will be upgraded from classic to named mode using the CLI command eigrp upgrade-cli <name> under the router process.
R1(config-router)#eigrp upgrade-cli NAMED_EIGRP
Configuration will be converted from router eigrp 100 to router eigrp NAMED_EIGRP.
Are you sure you want to proceed? ? [yes/no]: yes
R1(config)#
*Dec 1 12:42:23.769: EIGRP: Conversion of router eigrp 100 to router eigrp NAMED_EIGRP - Completed.
And now we verify the commands have been carried over from classic to named.
R1#show running-config | section router eigrp
router eigrp NAMED_EIGRP
!
address-family ipv4 unicast autonomous-system 100
!
af-interface Loopback0
passive-interface
exit-af-interface
!
af-interface GigabitEthernet1
no split-horizon
exit-af-interface
!
topology base
exit-af-topology
network 10.0.0.0 0.0.0.255
network 192.168.0.1 0.0.0.0
metric weights 0 0 0 1 0 0 0
exit-address-family
Now, all the commands that were scattered across the enabled interfaces and the router process has been put under the named mode router config. Namely, the passive-interface for loopback0, which was under the router process in classic mode, and the no split-horizon, which was under the gigabitethernet1 interface in classic mode.
There is a little shortcut in Cisco IOS worth mentioning, when working with named mode, that will shorten the command address-family ipv4 unicast autonomous-system 100 into a much more manageable address-family ipv4 as 100 command. This omits the unicast parameter and shortens autonomous-system to as.
There is a little shortcut in Cisco IOS worth mentioning, when working with named mode, that will shorten the command address-family ipv4 unicast autonomous-system 100 into a much more manageable address-family ipv4 as 100 command. This omits the unicast parameter and shortens autonomous-system to as.
The new command structure may seem a bit confusing at first, but when you need to configure, lets say, default authentication on all EIGRP enabled interfaces - or maybe set the Hello and Hold timers - you will love the af-interface default section of the multi-af configuration.
No comments:
Post a Comment